WordPress 5.3 Update – WP_Upgrader_Skin Warning

  • Resolved
    Posted in: Highend WP Theme  
  • Support
    November 22, 2019 at 8:12 pm #143483

    Older versions of Highend theme ( 3.6.1 and lower ) are incompatible with WP_Upgrader_Skin function in WordPress 5.3+.

    If you are seeing error like this:

    Warning: Declaration of HB_Upgrader_Skin::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in /home4/jgardenier/public_html/wp-content/themes/HighendWP/hbframework/admin/utilities/class-install-plugins.php on line 12

    your Highend theme version is not up to date and it’s not compatible with WordPress 3.5+.

    The solution for this issue is to update your Highend theme to version 3.6.2 or higher if available. You should be able to see a update pending for Highend theme in Dashboard » Updates.

    Unable to Login

    If you are unable to log in to your WordPress Dashboard to install the Highend 3.6.2+ update you will have to access your WordPress folder via hosting File Manager or FTP client and do one of the following:

    • – Replace HighendWP/hbframework/admin/utilities/class-install-plugins.php with the updated file.
    • Manually update Highend theme (by downloading the latest version from your MOJO Marketplace account and re-installing it).


    The correct HighendWP/hbframework/admin/utilities/class-install-plugins.php file that needs to be used is located below:


    In most cases the the file would be located on this path on your server:

    If you’re not sure how to access your website via File Manager / FTP you can contact your hosting company for assistance.

    If you need help with the process, reply to this topic and we will help.

    Thank you!

    Sorry, this forum is for verified users only. Please Login or Register to continue

Comments are closed.